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Using Accounting Link to exchange data  

with Sybiz Vision 

Overview 

Legrand CRM Accounting Link provides a simple, yet effective way to link your CRM data to your Sybiz Vision 

accounting data. Legrand’s Accounting Link further increases the effectiveness of your office systems by 

eliminating the need for double entries, and wasted time. 

With a few simple clicks, your sales people and account managers will be able to access a customer’s 

outstanding balances, contact information, credit limit and accounting notes, all within Legrand CRM’s 

consolidated information centre – allowing your team to operate more efficiently and more effectively. 

Benefits: 

1. Import Sybiz contacts into Legrand CRM 

2. Create new Customers in Sybiz from Legrand CRM 

3. Provide users with a customers sales history, listing the relevant customers invoices for a selected 
period of time. The interface also allows the user drill-down access to the Sybiz sales transaction. 

4. Ensure Customer addresses and Contact details are consistent between the CRM and accounting 

databases. 

5. Import a Customer’s Credit Status, Account Balances and Notes into Legrand CRM.  Once imported into 

the Legrand CRM database, these accounting summaries are available to all Legrand CRM users, 

including remote users who will get the latest update when they synchronize their database. 

6. Provides your front office staff (using Legrand CRM) with financial summaries about your Customers 

without providing direct access to the Sybiz accounting system. 

Sybiz Requirements 

• Sybiz Vision Accounting must be installed on the computer(s) that will run Accounting Link. 

• Although not strictly a requirement, the Accounting Link will operate faster if Sybiz is running on your 

computer when you execute Accounting Link. 

• Sales transaction drill down feature requires that Sybiz be installed on the machine viewing or drilling 

down into the sales invoices. 

Legrand CRM Requirements 

• Accounting Link works with Legrand CRM V4 PRO and CORP editions. 

• Accounting link is licensed per Legrand CRM serial number and requires an activation key to operate. 
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Installing and activating Accounting Link 

Installing Accounting Link is easy.  All you need is to 

copy the file sybiz.app into your Legrand application 

directory (This will usually be placed in your 

C:\LegrandCRM directory by default during the 

Legrand installation process).   

To enable the use of Accounting Link you will need to 

record the activation key, which is a 10-character 

code linked to your Legrand CRM serial number. 

To record the activation key, first log into Legrand 

CRM and then select Help > About from the menu at 

the top of the screen; then click on the “Record 

License” button on the About screen. 

When presented with the License Registration 

screen, simply enter the 10-character activation code 

for the Accounting Link option. 

 

If you are setting up the Accounting interface on a trial copy of Legrand CRM a license code is not 

required.   

Configuring Accounting Link 

After you have recorded the activation code the next step is to specify in Legrand CRM to which accounting 

database the current CRM database is going to be linked to. 

You will need to have System Administration user access rights to perform this function. In the menu at the top 

of the screen select Administration > System Administration then click on the command button System Options, 

then click on the button Accounting System. 

You will then be presented with a screen where you will specify the accounting system that this Legrand CRM 

database will link to. 

Every Legrand CRM database can have its own Accounting Link.  If you operate multiple Legrand CRM 

databases and multiple accounting systems you can actually link one Legrand CRM database with a Sybiz 

database, and link a second Legrand CRM database to another Sybiz database or even to another 

accounting system from one of the other supported suppliers.  

In the Accounting Link Setting screen simply 

click on the accounting system (i.e. in this 

case, Sybiz) and then click on the browse 

button to navigate to the Sybiz data file (i.e. 

map to the database folder which holds the 

Customer.DBF file).   
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Importing from Sybiz 

To run the Accounting Link interface go to the menu at the top left of the screen and select File > Import > 

Accounting Data > Link to Sybiz...  

Due to differences in the way many clients store delivery address information in Sybiz, Legrand now allows 

users to specify the mapping sequence between Sybiz delivery fields and Legrand Address fields. 

To configure the mapping, from the 

Interface window, select View Settings. 

You can then opt to include or exclude 

the Sybiz Delivery Note fields when 

mapping address fields between Sybiz 

and Legrand. Select “Save Settings” 

before continuing in order to retain any 

changes made. 

In most cases the first time import is 

when you want to transfer all your 

Customer accounts from Sybiz to your 

Legrand CRM database.  All you need 

to do is tick the “Scan Sybiz for new 

accounts to be created in Legrand 

CRM” box.  

 

 

 

 

 

 

 

 

 



  

  

Page 4 of 8 

 

The next step in the Accounting Link wizard will then scan your Sybiz data and will present you with the list of 

Customer accounts that exist in Sybiz but not in Legrand CRM. 

You then have the option to specify 

exactly which accounts are to be 

transferred across from Sybiz and 

created in Legrand CRM.  

In this example we will only process 

three accounts.  First click on “Unselect 

All” to clear all selections and then click 

on the check box for Evergreen Tours, 

Eylward Cane Supplier and Azzuri 

Chemical Suppliers to select these 

three accounts. 

 

 

Click on through the next steps in the Accounting Link wizard and the system will process all the Customer 

accounts you have selected, creating each one in Legrand CRM.  Upon completion of the wizard click on “All 

Companies” in Legrand CRM to show all companies, including all those just created by the Accounting Link 

wizard. 

Note. The above step will need to be run anytime you create a customer in Sybiz and require it to be transferred 

to the Legrand CRM database.  

 

   

Click on the “Accounting” tab to bring forward the accounting data section.  You will notice that even though the 

Customer record has been created in Legrand CRM the financial summaries have not yet been brought across, 

but you will notice that Accounting Link has recorded in the unique Sybiz Customer ID for each account it has 

created in Legrand CRM. 

To bring across the financial 

summaries it is simply a matter of 

running the Accounting Link wizard a 

second time, but this time we select to 

“Get the latest financial data”.   
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When the Accounting Link has completed you can view the Aged Balances of this customer in Legrand 

CRM, as well as any Customer notes in Sybiz and the Customer’s credit limit.  

 

For users with a valid accounting interface license, an installation of Sybiz on the same machine, and access to 

the Sybiz database this data will be display as ‘live’ i.e. when selecting a company Legrand CRM will access the 

Sybiz database to update the information displayed.  

Users without a live link i.e. without an Legrand Accounting Link license, without Sybiz Vision installed on the 

same machine or without a connection to the Sybiz data e.g. a travelling synchronization user, the information 

will be as recent as when the import of financials was last updated. 

The accounting link should only be run by a Legrand installation that has the Optional Accounting Link 

License, has access to the Sybiz database AND has Sybiz installed on the same machine.   

The Updated on field displays when the information was last updated.  

 

Sybiz users with a valid accounting interface license will also be able to get ‘live’ access to the 

list of customer transactions in Sybiz for the current Customer record in Legrand CRM. This 

information can be filtered for 7 or 15 days, 1, 3, 6 or 12 months, or ALL. 

While viewing the transactions listing there is also a drill down function. Simply by double 

clicking on an invoice in Legrand CRM, the corresponding transaction details are displayed 

within Legrand in a new window.  

It is now possible to drill down and open multiple sales invoices simultaneously. A new window will be 

opened for each invoice opened from within Legrand.  
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Note. Sales transaction drill down feature does not require Sybiz to be running. 

 

Creating a new Customer in Sybiz 

Creating a new customer in Sybiz from Legrand CRM can be performed in two ways. 

For Users without a ‘live’ link it is a simple two-step process. 

The first step is to identify, or mark, in Legrand CRM the Customer record that needs to be created in Sybiz.   

Simply navigate to the appropriate company record in Legrand CRM and click on the Accounting tab to show the 

accounting data section. 

Left-mouse click on the blue underlined Accounting Menu label to pop up a menu of commands, then select the 

“Create Next Time” command. 

 

That’s it!  Next time you run the Accounting Link you can elect to create this record in Sybiz by selecting the 

option to “Scan Legrand for new accounts to be created in Sybiz”. 
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For Users with a ‘live’ link it is even easier. 

Left-mouse click on the blue underlined Accounting Menue label to pop up a menu of commands, then select 

the “Create Now” command. 

After you have run Accounting Link wizard you will notice that the appropriate record has been created in Sybiz, 

and the Sybiz unique customer id has been recorded in the Legrand CRM database. 

Link Legrand record to existing Sybiz entity 

In some cases, the same company record may exist in both Sybiz and Legrand CRM. In such an instance, it is 

necessary to link these two existing entities.  

This is a simple 

process. First locate 

the record to be 

linked in Sybiz, and 

take note of the 

customer number in 

Sybiz. 

 

 

In Legrand CRM, navigate to the desired record. Once on this record, select the Accounting Tab and select “Link 

to Existing Accounting Entity”. You will then be able to copy the Sybiz customer number into the “Code” field in 

the Accounting tab within Legrand. Selecting save will then transfer the Sybiz unique ID to Legrand, and thereby 

link the two entities in the two applications. 

Viewing Item Sales Histories from within Legrand 

As an added feature, users with the Legrand Accounting Link to Sybiz can also view goods and service Sales 

Histories for customers linked to a Sybiz entity. 

This is done by selecting the Item Sales History button from the Accounting Tab in 

Legrand.  

This feature opens a new window 

that will display the different Item 

Sales to the customer in a selected 

period of time. It is also possible to 

view Item Sales Orders placed by 

this customer during a selected 

period of time. 

These results can then be sorted as 

desired by clicking on the column 

headers.  

This will be an invaluable tool for 

customer service representatives 

who can, literally at the click of a 

button, view the item sales histories 

and product preferences of a 

customer.  
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Conclusion 

Simple, yet effective.  The Accounting Link wizard enables you to transfer your Customer records from Sybiz to 

Legrand CRM, enables you to create new customer accounts in Sybiz from Legrand CRM, and enables you to 

store accounting summaries in Legrand CRM on every customer that has been linked to Sybiz. 

 

#   #   # 

 


