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Overview 
SQL Server is a powerful, but sophisticated and complex database system with many configuration options, 
not the least in the area of user security and access rights. Consequently there are many ways that these 
supposedly simple installations can go wrong, particularly if the SQL server is already tightly configured. 
 
This application note describes the steps you must follow to set up a Legrand SQL database for use with 
Legrand CRM CORP edition. While a number of wizards have been created to help you perform these tasks 
quickly it is important that a qualified SQL Database Administrator performs these tasks. 
 
Please note that Legrand Software does not provide support for SQL Administration tasks and that any SQL-
type questions will only be answered if asked by a SQL Database Administrator. 
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Installing LegrandCORP  
 

1. Ensure the server has been installed with SQL server. Users may wish to install SQL Client Tools on 
the workstation, so the enterprise manager can be used from the workstation to configure the SQL on 
the server.  Please note, users wishing to use the SQL replication tool (synchronisation), will need to 
install SQL server software on the workstation (MSDE minimum + SQL client tools).  

2. Confirm what type of authentication the SQL server is running. To connect to a SQL server you need 
to supply the server with a set of credentials. These can be in a mixed SQL and Windows 
authentication mode or just in Windows authentication mode. There are pro’s and con’s to each 
setup. 

3. Run the LegrandCORP installation on the workstations as desired. 

4. Register the workstations for LegrandCORP and ensure that the workstations can connect to the 
server as a workstation on the network. This is to make sure that the connection between the SQL 
server and the workstation is functioning. This will confirm the necessary SQL services on the server 
are running (or they may need restarting).  

5. Users wishing to use synchronization, create new databases or upsize existing Legrand PRO 
database will need to run the Enterprise Manager and connect the server to the workstation manager. 
This is done by right clicking on the SQL server group and clicking new SQL server registration and 
following the wizard. If the SQL server on which the LegrandCRM database will be located is not 
visible in Enterprise Manager you will need to register that SQL server in the SQL server group (right 
mouse click on “SQL server group” and select new SQL server registration, from here follow the set 
up wizard). 
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Creating a New Database 
 

1. Run the LegrandNewCORP.exe 

 
 

2. Enter server name. Then enter database name that will be created.  

  

3. If SQL server is on the remote PC you have to manually create a share name with the same name as 
database name. Please, use the following default folder: C:\Legrandcommon\ and create a folder with 
the same name as database name and share it, giving the desired users (groups) full access rights. 
This folder will be used to store company files and letters. Please note, you will also need to ensure 
you have correct windows permissions to access the PC running SQL server. Once the database is 
created you can change the common folder Changing the LegrandCORP Common Folder. Page 5 of 
this document. 

 

4. Creating a new database can take a minute or two. Please, wait for success message.  

 
 

5. Please ensure the database permissions are set as detailed in the  
Permission section page 15 of this documentation  

 

6. Start LegrandCORP.exe 
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7. Creating a new database should have created an entry in Select Datafiles. Select ‘select’ from the log 
in screen.  

User name: Demo 

Password:                  (blank) 

 
 

8. On other PCs wishing to access this you will need to add this connection: 

From the log on screen access via: select > add 

Enter database name, select SQL for Data Type and enter the server name in the Data Path box. 

 
 

 

By default Legrand CRM CORP Edition uses Windows Trusted Connection to establish a connection to the SQL database. If you want to, 
or need to, you can use SQL Server Authentication when running the Legrand wizards for creating a SQL database and upsizing a PRO 
database to a SQL database. 

Please note that while the Legrand CORP application does give you this option, using Windows Trusted Connection is recommended 

 

 

 

 

 

 

 



Legrand CRM CORP setup  Page 5 of 17 

Changing the LegrandCORP Common Folder. 
It is possible for a user with the appropriate user permissions to change the LegrandCORP Common 
(documents) folder. 

Files stored in this folder relate to, files attached to a company or activity note, templates, etemplates and log 
files. Access via Administration > System Administration > System Options > CORP common folder. 

It is highly recommended that this procedure is only performed by a network administrator when it is possible 
to obtain exclusive access to the database, there are two main reasons for this 

• The existing files need to be manually copied from the current folder to the desired new one, failure to 
do this will result in documents no longer being accessible from the LegrandCORP database, copying 
these files will require exclusive access to the Common Folder. 

• The change will not take effect until Legrand CRM user’s next log in. 
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Upgrading v3 to v4 Database 
 

1. Run the LegrandUpgradeCORP.exe 

 

 

2. Enter server name. Then enter database name to be upgraded, select upgrade.  

3. Once completed you will be presented with the below message. 

 

 

1. Please ensure the database permissions are set as detailed in the  
Permission section page 15 of this documentation  

 

2. Start LegrandCORP.exe 

 

3. You will need to add the new database to the Select Datafiles section. Select select > add from 
the log in screen.  

Enter database name, select SQL for Data Type and enter the server name in the Data Path box. 

 

By default Legrand CRM CORP Edition uses Windows Trusted Connection to establish a connection to the SQL database. If you want to, 
or need to, you can use SQL Server Authentication when running the Legrand wizards for creating a SQL database and upsizing a PRO 
database to a SQL database. 

Please note that while the Legrand CORP application does give you this option, using Windows Trusted Connection is recommended 
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Setting up Synchronisation (SQL replication) 
Legrand CRM CORP edition uses native SQL Server replication functionality to implement synchronization 
between the master SQL database and laptop users or remote users. 
 

The benefits of using SQL Merging Replication for Legrand synchronization is that it is fast, completely 
controllable by the SQL Database Administrator, and that detailed logs are kept by the SQL server.  

Also as this is a true client/server database, when performing replication, the local computer sends data 
request to the SQL Server application and this in turn extracts the data from the database and send the 
records to the client. Synchronization using Legrand CORP thus needs to transfer far less data than the STD 
and PRO editions and can be set up to run over a strong VPN connection, as well as a LAN. 

There are a couple of downsides, however, compared to the synchronization in STD and PRO. The first 
downside is that documents and templates are not synchronized. This is because the documents and 
templates are not stored within the SQL database itself but are stored in the selected shared folder directory. 
SQL Replication works on SQL data, it doesn’t handle the document attachments that are stored in the 
shared folder. 
 
However, with the release of v4, CORP users are now able to specify the desired shared folder which stores 
the Legrand database documents. Using the Windows 2000 and XP option of ‘Mark Available Offline’ users 
can have changes made to these documents updated using the synchronization feature of this Windows tool 
when they connect to the network. Please see Using Windows O/S ‘Make Available Offline’ tool, to 
synchronize documents on page 12 for more detail. 

 
The second downside is that any change to the SQL database structure will mean that SQL replication will 
cease to work. Users will have to delete the Replica databases on every remote PC/laptop and will have to 
delete all subscriptions for the database at the master server. Then, after the data structure changes have 
been performed at the master server users will need to re-activate Publication using sqlcrmReplication.exe 
and recreate new replica databases using the sqlcrmSubscribe.exe wizard. 
 
Note. If running SQL enterprise manager from the SQL server, please create a registration for the server 
other than ‘(local)’, servers registered as (local) do not support replication.  
 

1. Install Microsoft SQL Server (or MSDE) on the local workstation + SQL client tools. 

 

2. Ensure the SQL user for whom the replication is being set up for, has the correct permissions as 
defined in the Permissions section on page 15 of this documentation. Replication users require the 
same access to the Legrand Master database as users logging on directly, the reason for this is 
Customer Service issues created remotely require to be updated with a unique ticket number, and the 
database must be both accessed and updated too to complete this step.  

 

3. Share the following folder on the server where Legrand Master database is located: 
C:\Program Files\Microsoft SQL Server\MSSQL\repldata with REPLDATA as the share name. Ensure 
users have full read / write permissions to this folder. 

Note. Please ensure these permissions are set on both the security tab and sharing > permissions 
section of this folder. 

 

You do NOT need to share the same folder on the local server where the local database is going to 
be. 
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4. Set the security settings on the SQL server to allow SQL Server and Windows Authentication. 
Access via Enterprise Manager > Select the SQL Server > Right Mouse Click > Properties > Security 
Tab. 

 
SQL Server and Windows are recommended. 

 

5. Set SQLSERVERAGENT and MSSQLSERVER services, on the SQL server, to log on as a local user 
account with full access rights to the local computer: Access via Control Panel > Administrative Tools 
> Services > SQLSERVERAGENT / MSSQLSERVER. 
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Ensure that MSSQLSERVER it is set to start automatically: 

 
MS SQL SERVER service should be set to Automatic. It is possible to have startup type set to either 
Manual or Disabled, this will require users to start MSSQLSERVER manually when they wish to 
access the local database. 

 

6. THE COMMON FOLDER ON THE SERVER IS REQUIRED TO BE SHARED. SO THAT WHEN THE 
REPLICATION OCCURS IT CAN CONNECT AND COPY THE FILES FROM THERE TO THE 
LOCAL WORKSTATION. 

 

7. As a test please ensure that the workstation can connect to the server as a workstation on the 
network. This will confirm that the connection between the SQL Server and the workstation is 
functioning. 

 

8. To run the first synchronization to a database, the database must first be published on the SQL 
Server. To do this run Start sqlcrmReplication.exe. To connect to a SQL server you need to supply 
the server with a set of credentials. Select the Setup Replication button. 

 
Please note that the name you specify for the database is case sensitive.  You will need to use 
exactly the same name in step 12. 
 

9. During the Replication setup you will be asked to enter a password for LegrandCRM_Admin login. 
This is a new login be created and please note the password as it will be needed when subscribing 
to the master database. 
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Please take note of this password as it will be required in step 12 below. 

You will receive the following message. 

 
Please wait while the snapshot is created, you can check the status of this by checking the 
Replication Monitor (see below) in SQL Enterprise Manager. 

This will publish the database for replication on the server. 

Note: As a result you will get ‘Replication Monitor’ icon in SQL Server Enterprise Manager. Here you 
can monitor subscriptions to the master database: 

 
 

Note.  Steps 7 and 8 only needs to be run when a database is first published for replication. 

 

10. Start sqlcrmSubscribe.exe and enter required fields. 

11. Confirm the type of authentication the SQL server is running. To connect to a SQL server you need to 
supply the server with a set of credentials. Select Subscribe. 

12. During the setup you will be asked to enter password the created in step 8 for LegrandCRM_Admin 
login.  
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This will copy the Legrand Common folder to the local C drive. 

 

13. You will then receive the below confirmation message. 

 
 

14. Run the Initial Synchronisation. 

15. This will have created a local copy of the master database. The local database name is by default: 
“Master database name” with a “_replica” attached to it. 

16. When logging into the local LegrandCORP database you can synchronise any time by selecting: 

File > Synchronisation > Synchronise Data 

 

Note. The common default setting for MS SQL server databases is to drop subscriptions if not  

          synchronized within 14 days.  

It is recommended extending this if you have synchronized users that may not sync within this 
timeframe.  

Access via > Enterprise manager > Server > Replication monitor > publishers > server > database 
> (rmb) properties. 

 
 

If the subscription expires you will need to upload any changes from the Subscriber to the Publisher 
manually, please see the below link for information regarding this.  

http://msdn2.microsoft.com/en-us/library/ms152558.aspx  
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Using Windows’ ‘Make Available Offline’ tool, to synchronize documents. 
Using the Windows 2000 and XP ‘Make Available Offline’ tool, it is possible to synchronise 
documents attached to the database when reconnecting to the network. Folders and files that are 
made available offline, will be synchronized when user reconnects to the network. 

To set up your computer to use offline files 

1. Open My Computer (Windows Explorer).  

2. Navigate to the server that contains the “Legrand Common” folder group and select the 
“common” folder (the folder has the same name as the SQL Server database that has already 
been created in the previous steps). 

3. On the Tools menu, click Folder Options.  

4. On the Offline Files tab, make sure that the Enable Offline Files check box is selected.  

5. Select Synchronize all offline files before logging off to get a full synchronization.  

6. The ‘licenses’ folder does not need to be synchronised so once the initial synchronisation has 
completed, select the “Licences” folder which is located directly under the “common folder”. 

7. Right click on the Licence folder and select Make Available Offline to remove the tick icon 
from its selection in the menu. By removing the tick icon the folder is skipped during 
synchronisation. 

8. Map as a network drive the desired Legrand CORP database documents folder. 

9. Select the network drive as above to view its contents.  

10. On the File menu, click Make Available Offline and follow the wizard selecting to make this 
folder and all subfolders available. 

Notes 

To open My Computer, double-click the My Computer icon on the desktop.  

If you want to control which offline files are synchronized, when they are synchronized, and whether 
Windows prompts you before synchronizing your files, you can use Synchronization Manager.  

If My Computer does not contain links to any network drives, you need to assign a drive letter to a 
shared network resource.  

To view a list of all of the shared network files that are available offline, on the Tools menu, click 
Folder Options. On the Offline Files tab, click View Files.  

For more detail on this feature, please see the Help and Support Centre of My Computer. 

After the folder has been made available offline, you will need to select the appropriate folder in the 
local Legrand CRM CORP database. 

11. Login to the local database (i.e. newdatabase_replica) and select to change the default 
common folder to the appropriate folder.  

 

When set up correctly the common folder for both the master and the local databases will be the 
same. 
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Upsizing LegrandPRO to LegrandCORP 
Upsizing an existing Legrand CRM database can only be performed on a Legrand PRO database, if the 
database you are wishing to upsize is a Legrand STD database, you will first need to upgrade this to Legrand 
PRO. 

 

1. Start LegrandUpsizeCORP.exe 

 
 

2. Enter server name. Enter database name that will be created. Select existing PRO database to be 
upsized to SQL.  

Note: If SQL server is on the remote PC you have to manually create a share name with the same 
name as database name. Please, use the following default folder: C:\LegrandCommon\ and 
create a folder with the same name as database name and share it. This folder will be used to 
store company files and letters. In the next version of LegrandCORP we intend to put all the 
files in SQL database. 

 
 

3. Upsizing may take a minute or two. Please, wait for success message.  

 

4. Ensure all users for whom the access is desired, has the correct permissions as defined in the 
Permissions section on page 154 of this documentation.  

 

5. Start LegrandCORP.exe 

 



Legrand CRM CORP setup  Page 14 of 17 

6. Upsizing procedure should have created an entry in Select Datafiles. 

 
 

7. On the other PCs you should add this entry manually: 

 

 
 

8. Log in. 

 

By default Legrand CRM CORP Edition uses Windows Trusted Connection to establish a connection to the SQL database. If you want to, 
or need to, you can use SQL Server Authentication when running the Legrand wizards for creating a SQL database and upsizing a PRO 
database to a SQL database. 

Please note that while the Legrand CORP application does give you this option, using Windows Trusted Connection is recommended.  
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Database Permissions 
When setting up a new database or a new connection to an existing database, either replication or a network 
connection, is it very important to have the correct permissions set. The below permissions should be set for 
all Domain Users or Domain Groups that require access to the database.  

 

SQL Server Login Properties 

Access via the SQL Server Enterprise 
Manager, go to Microsoft SQL Servers 
> SQL Server Group > SQL server > 
Security > Logins. Ensure each login 
(Group) you want to access the 
database has the following SQL 
permissions set on the Data Access tab 

• Public 

• db_datareader  

• db_datawriter 

 

 

 

 

Please ensure a conflicting 
permission is not selected i.e.  

• db_denydatareader 

• db_denydatawriter 

 

If these permissions are not set 
correctly then one of the below 
errors will be encountered when 
trying to access the database. 
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Database User Properties 

Access via the SQL Server 
Enterprise Manager, go to 
Microsoft SQL Servers > SQL 
Server Group > SQL server > 
Databases > database > Users.  

 

 

 

 

Ensure each login (group) you 
want to access the database is   

1. Listed in the User list, and 

2. Has the following Database 
role membership set.  

• Public 

• db_datareader  

• db_datawriter 
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Errors Encountered. 

When trying to establish a connection to the 
database (i.e. at login screen) the error 
message Cannot make connection may 
be encountered.  

This error relates establishing a connection 
to the MS SQL server, and will usually relate 
to SQL (as above) permissions or Net logon 
service.  

 
 

 
 

 
 

The most common cause of this error is in 
fact the license being used by another user 
i.e. the license is installed on more than one 
machine. 

It can also be caused if the common folder 
does not have read / write access as 
specified in step 3 of Creating a New 
Database. 

 

 

 

When trying to establish a connection to the 
database (i.e. at login screen) the error message 
Cannot make connection may be encountered.  

This error relates establishing a connection to the MS 
SQL server, and will usually relate to SQL 
permissions or Net logon service. 

 

 


