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Application Note:  Using Accounting Link to exchange data 
with QuickBooks PRO, Premier and Enterprise  

1. Overview 

Legrand CRM Accounting Link provides a simple, yet effective way to link your CRM data to your QuickBooks PRO, Premier and 
Enterprise accounting data. Legrand’s Accounting Link further increases the effectiveness of your office systems by creating a 
seamless link between Legrand CRM and your QuickBooks PRO, Premier or Enterprise  accounting system – no more double 
entries, no more wasted time. 

With a few simple clicks, your sales people 
and account managers will be able to access 
a customer’s outstanding balances, contact 
information, credit limit, accounting notes 
and view sales line item details, all within 
Legrand CRM’s consolidated information 
center – allowing your team to operate more 
efficiently and more effectively. 

Benefits: 

1. Import QuickBooks contacts into 
Legrand CRM 

2. Create new Customers in 
QuickBooks from Legrand CRM 

3. Import QuickBooks sales 
transactions line item details into 
Legrand CRM’s Item Tracking 
module. 

4. Provide users with list of Posted (Invoices, Sales Receipts, Credit Memos) and Non Posted (Sales Orders, Estimates) 
sales transactions for every linked Customer, with drill-down access to the QuickBooks transaction. 

5. Ensure Customer addresses and Contact details are consistent between the CRM and accounting databases. 

6. Import a Customer’s Credit Status, Account Balances and Notes into Legrand CRM.  Once imported into the Legrand 
CRM database, these accounting summaries are available to all Legrand CRM users, including remote users who will get 
the latest update when they synchronize their database. 

7. Provides your front office staff (using Legrand CRM) with financial summaries about your Customers without providing 
direct access to the QuickBooks accounting system. 

2. QuickBooks Requirements 

• QuickBooks PRO, Premier or Enterprise or higher. 

• QuickBooks must be installed on the computer that will run Accounting Link. 
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• The Accounting Link will operate faster if QuickBooks is running on your computer when you execute Accounting Link. 
(This is a suggestion only, not a requirement)  

• Sales transaction drill down feature requires QuickBooks to be running. 

• Allow QuickBooks Preferences ‘integrated application’ access.  

3. Legrand CRM Requirements 

• Accounting Link works with Legrand CRM V4 PRO and CORP editions. 

• Accounting link is licensed per Legrand CRM serial number and requires an activation key to operate. 

4. Installing and activating Accounting Link 

Installing the Accounting Link is easy.  All you need is to 
copy the file QB.app and QBlink.app into your Legrand 
application directory.   

Note. By default both of these files are installed with the 
Legrand CRM installation.  

To enable the use of Accounting Link you will need to 
record the activation key, which is a 10-character code 
linked to your Legrand CRM serial number. 

To record the activation key, first log into Legrand CRM 
and then select Help > About from the menu at the top of 
the screen; then click on the “Record License” button on 
the About screen. 

When presented with the License Registration screen, 
simply enter the 10-character activation code for the 
Accounting Link option. 

 

If you are setting up the Accounting interface on a trial copy of Legrand CRM a license code is not required.  

5. Configuring Accounting Link 

After you have recorded the activation code, the next step is to specify the accounting database Legrand CRM database is going 
to be linked to. 

You will need to have System Administration user access rights to perform this function. In the menu at the top of the screen 
select Administration > System Administration then click on the command button System Options, then click on the button 
Accounting System.  You will then be presented with a screen where you will specify the accounting system that Legrand CRM 
database will link to. 

Every Legrand CRM database can have its own Accounting Link.  If you operate multiple Legrand CRM databases and multiple 
accounting systems you can actually link one Legrand CRM database with a QuickBooks database, and link a second Legrand 
CRM database to another QuickBooks database or even to another accounting system from one of the other supported suppliers.  
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In the Accounting Link Setting screen simply click 
on the accounting system (i.e. in this case, 
QuickBooks) and then click on the browse button 
to navigate to the QuickBooks data file (i.e. a file 
with a .qbw extension). 

 

 

6. Importing from QuickBooks 
Before running the interface for the first time please open QuickBooks.  

 
Go to File > Switch to Multi-
user mode (if it reads Switch to 
Single User Mode please do not 
change it).   
 
 

 
When you first run the steps 
below, QuickBooks will identify a 
3rd party application is trying to 
access the database, please allow 
access.   
 
If the pop up does not appear in 
QuickBooks please check that 
‘Don’t allow any applications to 
access this company file’ is not 
selected.   
 
Access via Edit > Preferences > 
Integrated Applications > 
Company Preferences (tab).  
Note. In earlier versions this menu 
may be located elsewhere.  

 
 

 

 

 

 

 

In Legrand CRM, to run the Accounting Link interface go to the menu at the top left of the screen and select File > Import > 
Accounting Data > Import from QuickBooks > Import Accounts & Summaries.   
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As mentioned above this, should cause the 
pop windows opposite to appear.  

Please select the “Yes” option that best 
suits your security requirements.  

 

In most cases, when import is carried out 
for the first time, the user may want to 
transfer all Customer accounts from 
QuickBooks to Legrand CRM database.  All 
you need to do is tick the “Scan QuickBooks 
for any accounts that do not exist in 
Legrand CRM” box. 

 

 

The next step in the Accounting Link wizard will then scan your QuickBooks data and will present you with the list of Customer 
accounts that exist in QuickBooks but not in Legrand CRM. 
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You then have the option to specify which 
accounts are to be transferred across from 
QuickBooks and created in Legrand CRM. 

In this example, we will only process three 
accounts.  First click on “Unselect All” to clear 
all selections and then click on the check box 
for Kristy Abercrombie, Mike Balak and Renee 
Barley to select these three accounts. 

 

 

Click “next” in the Accounting Link wizard and the system will process all the Customer accounts you have selected, creating 
each one in Legrand CRM.  Upon completion of the wizard click on “All Companies” in Legrand CRM to show all companies, 
including all those just created by the Accounting Link wizard. 

Note. The above step will need to be run anytime you create a customer in QuickBooks and require it to be transferred to the 
Legrand CRM database. 

 

 

Click on the “Accounting” tab to bring forward the accounting data section.  You will notice that even though the Customer 
record has been created in Legrand CRM the financial summaries have not yet been brought across.  You will also notice that 
Accounting Link has recorded the unique QuickBooks Customer ID for each account it has created in Legrand CRM. 

To bring across the financial summaries it is 
simply a matter of running the Accounting 
Link wizard a second time, but this time 
select “Get the latest financial data”.   

 

 

When the Accounting Link has completed you can view the Aged Balances of this customer in Legrand CRM, as well as any 
Customer notes in QuickBooks and the Customer’s credit limit.  

 

For users with a valid accounting interface license this data will be display as ‘live’ i.e. when selecting a company Legrand CRM 
will access the QuickBooks database to update the information displayed.  
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Users without a live link i.e. without an accounting interface license or without a connection to the QuickBooks data e.g. a 
traveling synchronization user, the information will be as recent as when the import of financials was last updated. 

The “Updated on” field displays when the information was last updated. 

 

Users with a valid accounting interface license will be able to get ‘live’ access to the list of Posted and Non Posted customer 
transaction in QuickBooks for the current Customer record in Legrand CRM.  

The information displayed for the Payments Outstanding amounts are based on preferences as set in QuickBooks i.e. the Reports 
and Graphs preferences ‘Aging Report’ and ‘Summary Reports Basis’. 

The payments outstanding totals are aged as below; it is recommended you change the Legrand CRM Screen Labels to match 
the QuickBooks data.  

Access via: Administration > 
System Administration > Screen 
Labels 

 

 

Viewing the transactions listing also allows for a drill down function. By double clicking on an invoice in Legrand CRM, the 
corresponding transaction is opened in QuickBooks. 
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• Note. Sales transaction drill down feature requires QuickBooks to be running 

•  

7. Importing Products and Items Sold  

• For Legrand CRM uses that also have the optional module ‘Item Tracking;’ you can also import your ‘key’ product lines 
and resulting Sales Line item details into Legrand CRM. Making the sales data available to all CRM users without needing 
access to QuickBooks.  

Go to the menu at the top left of the screen and select File > Import > Accounting Data > Import from QuickBooks > Import 
Products and Items Sales.  

•  

•  

•  
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• On your first import select Import Parts Information. 

•  

• Select the ‘key’ items you wish to import, you may not want to import freight into your CRM system.  

• Once you have selected these 
items, select Import / Update 
Selected Items.  

• This will import the QuickBooks 
items into the Legrand ‘Products’ 
module (this is a sub module of 
Item Tracking).    

• You will then receive a message 
stating the import / update has 
been completed successfully, 
select Back to Menu.  
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• Select Import Sales Transactions. 

• Enter an 
appropriate date 
range and select 
‘Execute 
Import’. 

• If this is the first 
time you have 
run this import 
this may take a 
few minutes.  

 

• This will import 
the QuickBooks 
sales transaction 
details into the 
Legrand Item 
Tracking module.   

 

 

8. Creating a new Customer in QuickBooks 

Creating a new customer in QuickBooks from Legrand CRM can be performed in two ways. 

For Users without a ‘live’ link it is a simple two-step process. 

The first step is to identify, or mark, in Legrand CRM the Customer record that needs to be created in QuickBooks.   Simply 
navigate to the appropriate company record in Legrand CRM and click on the Accounting tab to show the accounting data 
section. 

Left-mouse click on the blue underlined Accounting label to pop up a menu of commands, then select the “Create Next Time” 
command. 
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Next time you run the Accounting Link you can elect to create this record in QuickBooks. 

Please note that the system will only create the record in QuickBooks if you select the option in Accounting Link to “scan Legrand 
CRM for accounts to be created in QuickBooks”.   

 

For Users with a ‘live’ link it is even easier. 

Left-mouse click on the blue underlined Accounting label to pop up a menu of commands, then select the “Create Now” 
command. 

After you have run Accounting Link wizard you will notice that the appropriate record has been created in QuickBooks, and the 
QuickBooks unique customer id has been recorded in the Legrand CRM database. 

 

 

9. Conclusion 

Simple, yet effective.  The Accounting Link wizard enables you to transfer your Customer records from QuickBooks to Legrand 
CRM, enables you to create new customer accounts in QuickBooks from Legrand CRM, and enables you to store accounting 
summaries in Legrand CRM on every customer that has been linked to QuickBooks. 

 


